Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
LOW severity

@better-auth/drizzle-adapter: Concurrent requests can exceed rate limits on PostgreSQLGHSA-44jh-23m7-hpcf

LOWFix: better-auth/better-auth#11331

GHSA-44jh-23m7-hpcf is a low-severity (CVSS 3.7) CWE-307 vulnerability in @better-auth/drizzle-adapter. A fix is available for @better-auth/drizzle-adapter — see the affected versions and patch details below.

Also known asCVE-2026-110861
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-44jh-23m7-hpcf.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs12th percentile — riskier than 12% of all scored CVEsHighest risk

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

GHSA-44jh-23m7-hpcf by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.

Where this sits among everything scored

Of 396,257 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

3 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

37other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
better-authnpm
11.3Mdownloads / week

Description

Am I affected?

You are affected if you use @better-auth/drizzle-adapter from 1.6.17 through versions before 1.7.7 (including the 1.7.0 prereleases from beta.6 through rc.6) or @better-auth/kysely-adapter 1.6.17 through 1.6.31, and keep rate-limit records in a PostgreSQL database.

All of these must be true:

  • Rate limiting is enabled.
  • Rate-limit records are stored in the database.
  • The database is PostgreSQL, used through one of the adapter versions above.

You are not affected if you store rate-limit records in memory (the default) or in secondary storage.

Summary

Database-backed rate limiting on PostgreSQL can let a burst of concurrent requests go over the configured maximum. When many requests arrive at the same time, several of them can pass the limit check together. This weakens the rate limit on password sign-in, two-factor verification, one-time codes, password resets, and other rate-limited endpoints.

Impact

An attacker who sends many requests at once can make more attempts than the application allows.

The issue does not bypass password or one-time-code validation. It does not directly compromise an account. The number of extra attempts is limited by the number of concurrent database connections, the number of application instances, and the rate-limit window.

Patches

@better-auth/kysely-adapter is fixed in 1.7.0. Upgrade to 1.7.0 or later.

The Drizzle fix is merged for the planned @better-auth/drizzle-adapter 1.7.7 release. That package is not available yet. Upgrade better-auth and the installed Drizzle adapter together when 1.7.7 is available. No database schema or public API migration is required.

Workarounds

  • Store rate-limit records in secondary storage.
  • Use a custom rate-limit storage that checks and increments the counter in one atomic step. An atomic step cannot be interrupted by another request.
  • Enforce the intended limit at an upstream layer, such as a reverse proxy or gateway.

In-memory storage also avoids this issue. However, each application instance keeps its own counter, so it may not enforce one shared limit in multi-instance or serverless deployments.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
📦npm@better-auth/drizzle-adapter≥ 1.6.17&&< 1.7.71.7.7npm install @better-auth/drizzle-adapter@1.7.7
📦npm@better-auth/kysely-adapter≥ 1.6.17&&< 1.7.01.7.0npm install @better-auth/kysely-adapter@1.7.0
📦npmbetter-auth≥ 1.6.17&&< 1.7.71.7.7npm install better-auth@1.7.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @better-auth/drizzle-adapter, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @better-auth/drizzle-adapter to 1.7.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-44jh-23m7-hpcf is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

## Am I affected? You are affected if you use `@better-auth/drizzle-adapter` from 1.6.17 through versions before 1.7.7 (including the 1.7.0 prereleases from beta.6 through rc.6) or `@better-auth/kysely-adapter` 1.6.17 through 1.6.31, and keep rate-limit records in a PostgreSQL database. All of these must be true: - Rate limiting is enabled. - Rate-limit records are stored in the database. - The database is PostgreSQL, used through one of the adapter versions above. You are not affected if you store rate-limit records in memory (the default) or in secondary storage. ## Summary Database-ba
O3 Security · Impact-Aware SCA

Is GHSA-44jh-23m7-hpcf in your dependencies?

Find it across npm, including transitive dependencies.

@better-auth/drizzle-adapter: Concurrent requests can…