CVE-2026-32203 — dotnet
CVE-2026-32203 is a Improper Input Validation vulnerability in dotnet. A fix is available for dotnet — see the affected versions and patch details below.
.NET and Visual Studio Denial of Service Vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-32203.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
dotnetReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Bitnami packages — download data is not available via public APIs for these ecosystems.
Description
Stack-based buffer overflow in .NET and Visual Studio allows an unauthorized attacker to deny service over a network.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦Bitnami | dotnet | ≥ 8.0.0&&< 8.0.26 | 8.0.26 |
Affected Products
.netmicrosoftvisual studio 2022microsoftvisual studio 2026microsoftDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dotnet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update dotnet to 8.0.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-32203 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This is an Important denial of service vulnerability in .NET, affecting Red Hat Enterprise Linux and Fedora. The flaw, a stack overflow in EncryptedKey nested decryption, could allow an attacker to cause a denial of service.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-32203 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | dotnet10.0-0:10.0.106-1.el10_1 | RHSA-2026:8467 |
| Red Hat Enterprise Linux 10 | dotnet8.0-0:8.0.126-1.el10_1 | RHSA-2026:8470 |
| Red Hat Enterprise Linux 10 | dotnet9.0-0:9.0.116-1.el10_1 | RHSA-2026:8472 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | dotnet9.0-0:9.0.116-1.el10_0 | RHSA-2026:13280 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | dotnet8.0-0:8.0.126-1.el10_0 | RHSA-2026:13281 |
| Red Hat Enterprise Linux 8 | dotnet8.0-0:8.0.126-1.el8_10 | RHSA-2026:8468 |
| Red Hat Enterprise Linux 8 | dotnet10.0-0:10.0.106-1.el8_10 | RHSA-2026:8473 |
| Red Hat Enterprise Linux 8 | dotnet9.0-0:9.0.116-1.el8_10 | RHSA-2026:8475 |
Frequently Asked Questions
Is CVE-2026-32203 in your dependencies?
Find it across Bitnami, including transitive dependencies.