CVE-2025-15022 — vaadin-server
Fix: vaadin/flow-components#8285CVE-2025-15022 is a Cross-site Scripting (XSS) vulnerability in com.vaadin:vaadin-server. A fix is available for com.vaadin:vaadin-server — see the affected versions and patch details below.
Cross-site scripting in Action caption
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-15022.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
com.vaadin:vaadin-server☕com.vaadin:vaadin-server☕com.vaadin:vaadin☕com.vaadin:vaadin☕com.vaadin:vaadin☕com.vaadin:vaadin-spreadsheet-flow☕com.vaadin:vaadin-spreadsheet-flow☕com.vaadin:vaadin-spreadsheet-flowReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Action captions in Vaadin accept HTML by default but were not sanitized, potentially allowing Cross-site Scripting (XSS) if caption content is derived from user input.
In Vaadin Framework 7 and 8, the Action class is a general-purpose class that may be used by multiple components. The fixed versions sanitize captions by default and provide an API to explicitly enable HTML content mode for backwards compatibility.
In Vaadin 23 and newer, the Action class is only used by the Spreadsheet component. The fixed versions sanitize HTML using Jsoup with a relaxed safelist.
Vaadin 14 is not affected as Spreadsheet component was not supported.
Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include:
Product version Vaadin 7.0.0 - 7.7.49 Vaadin 8.0.0 - 8.29.1 Vaadin 23.1.0 - 23.6.5 Vaadin 24.0.0 - 24.8.13 Vaadin 24.9.0 - 24.9.6
Mitigation Upgrade to 7.7.50 Upgrade to 8.30.0 Upgrade to 23.6.6 Upgrade to 24.8.14 or 24.9.7 Upgrade to 25.0.0 or newer
Artifacts Maven coordinatesVulnerable versionsFixed versioncom.vaadin:vaadin-server 7.0.0 - 7.7.49 ≥7.7.50 com.vaadin:vaadin-server 8.0.0 - 8.29.1 ≥8.30.0 com.vaadin:vaadin 23.1.0 - 23.6.5 ≥23.6.6 com.vaadin:vaadin24.0.0 - 24.8.13 ≥24.8.14 com.vaadin:vaadin24.9.0 - 24.9.6 ≥24.9.7 com.vaadin:vaadin-spreadsheet-flow 23.1.0 - 23.6.5 ≥23.6.6 com.vaadin:vaadin-spreadsheet-flow 24.0.0 - 24.8.13 ≥24.8.14 com.vaadin:vaadin-spreadsheet-flow 24.9.0 - 24.9.6 ≥24.9.7
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.vaadin:vaadin-server | ≥ 7.0.0&&< 7.7.50 | 7.7.50com.vaadin:vaadin-server:7.7.50 |
| ☕Maven | com.vaadin:vaadin-server | ≥ 8.0.0&&< 8.30.0 | 8.30.0com.vaadin:vaadin-server:8.30.0 |
| ☕Maven | com.vaadin:vaadin | ≥ 23.1.0&&< 23.6.6 | 23.6.6com.vaadin:vaadin:23.6.6 |
| ☕Maven | com.vaadin:vaadin | ≥ 24.0.0&&< 24.8.14 | 24.8.14com.vaadin:vaadin:24.8.14 |
| ☕Maven | com.vaadin:vaadin | ≥ 24.9.0&&< 24.9.7 | 24.9.7com.vaadin:vaadin:24.9.7 |
| ☕Maven | com.vaadin:vaadin-spreadsheet-flow | ≥ 23.1.0&&< 23.6.6 | 23.6.6com.vaadin:vaadin-spreadsheet-flow:23.6.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.vaadin:vaadin-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.vaadin:vaadin-server to 7.7.50 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-15022 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2025-15022 in your dependencies?
Find it across Maven, including transitive dependencies.