NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
LOW severity

CVE-2021-31403 — vaadin-bom

LOWFix: vaadin/framework#12188

CVE-2021-31403 is a low-severity (CVSS 2.5) CWE-208 vulnerability in com.vaadin:vaadin-bom. A fix is available for com.vaadin:vaadin-bom — see the affected versions and patch details below.

Timing side channel vulnerability in UIDL request handler in Vaadin 7 and 8

Also known asGHSA-75xc-qvxh-27f8
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs23th percentile — riskier than 23% of all scored CVEsHighest risk
0.00%0.27%0.54%0.81%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕com.vaadin:vaadin-bom☕com.vaadin:vaadin-bom☕com.vaadin:vaadin-server☕com.vaadin:vaadin-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Non-constant-time comparison of CSRF tokens in UIDL request handler in com.vaadin:vaadin-server versions 7.0.0 through 7.7.23 (Vaadin 7.0.0 through 7.7.23), and 8.0.0 through 8.12.2 (Vaadin 8.0.0 through 8.12.2) allows attacker to guess a security token via timing attack

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.vaadin:vaadin-bom≥ 7.0.0&&< 7.7.247.7.24com.vaadin:vaadin-bom:7.7.24
☕Mavencom.vaadin:vaadin-bom≥ 8.0.0&&< 8.12.38.12.3com.vaadin:vaadin-bom:8.12.3
☕Mavencom.vaadin:vaadin-server≥ 7.0.0&&< 7.7.247.7.24com.vaadin:vaadin-server:7.7.24
☕Mavencom.vaadin:vaadin-server≥ 8.0.0&&< 8.12.38.12.3com.vaadin:vaadin-server:8.12.3

Affected Products

1 product · 2 configurations
Application
vaadinvaadin
≥ 8.0.0 && < 8.12.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.vaadin:vaadin-bom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.vaadin:vaadin-bom to 7.7.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-31403 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Non-constant-time comparison of CSRF tokens in UIDL request handler in `com.vaadin:vaadin-server` versions 7.0.0 through 7.7.23 (Vaadin 7.0.0 through 7.7.23), and 8.0.0 through 8.12.2 (Vaadin 8.0.0 through 8.12.2) allows attacker to guess a security token via timing attack - https://vaadin.com/security/cve-2021-31403
O3 Security · Impact-Aware SCA

Is CVE-2021-31403 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-31403: vaadin-bom CSRF — Fixed in 7.7.24