CVE-2024-41818 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in fast-xml-parser. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for fast-xml-parser — see the affected versions and patch details below.
ReDOS at currency parsing fast-xml-parser
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-41818.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
fast-xml-parsernpmDescription
Summary
A ReDOS that exists on currency.js was discovered by Gauss Security Labs R&D team.
Details
https://github.com/NaturalIntelligence/fast-xml-parser/blob/v4.4.0/src/v5/valueParsers/currency.js#L10 contains a vulnerable regex
PoC
pass the following string '\t'.repeat(13337) + '.'
Impact
Denial of service during currency parsing in experimental version 5 of fast-xml-parser-library
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | fast-xml-parser | ≥ 4.3.5&&< 4.4.1 | 4.4.1npm install fast-xml-parser@4.4.1 |
Affected Products
fast-xml-parsernaturalintelligenceResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fast-xml-parser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update fast-xml-parser to 4.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-41818 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat has decided to rate this vulnerability as Important due to the potential loss of Availability and the low complexity.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Developer Hub 1.2 on RHEL 9 | rhdh/rhdh-hub-rhel9:1.2-136 | RHBA-2024:5958 |
| RHEL-9-CNV-4.16 | container-native-virtualization/kubevirt-console-plugin-rhel9:v4.16.1-107 | RHSA-2024:5054 |
| RHOAI-2.13-RHEL-8 | rhoai/odh-codeflare-operator-rhel8:v2.13.1-1 | RHBA-2024:8413 |
| RHODF-4.14-RHEL-9 | odf4/mcg-core-rhel9:v4.14.11-1 | RHSA-2024:7624 |
| RHODF-4.16-RHEL-9 | odf4/mcg-core-rhel9:v4.16.2-2 | RHSA-2024:6755 |
| RHODF-4.17-RHEL-9 | odf4/mcg-core-rhel9:v4.17.0-69 | RHSA-2024:8676 |
Frequently Asked Questions
Is CVE-2024-41818 in your dependencies?
Find it across npm, including transitive dependencies.