NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2024-38808 — spring-expression

MEDIUMFix: spring-projects/spring-framework@26f2dad

CVE-2024-38808 is a medium-severity (CVSS 4.3) CWE-770 vulnerability in org.springframework:spring-expression. A fix is available for org.springframework:spring-expression — see the affected versions and patch details below.

CVE-2024-38808: Spring Expression DoS Vulnerability

Also known asGHSA-9cmq-m9j5-mvww
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-38808.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.04%0.46%0.88%1.31%0.8%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.springframework:spring-expression

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Spring Framework versions 5.3.0 - 5.3.38 and older unsupported versions, it is possible for a user to provide a specially crafted Spring Expression Language (SpEL) expression that may cause a denial of service (DoS) condition. Older, unsupported versions are also affected.

Specifically, an application is vulnerable when the following is true:

  • The application evaluates user-supplied SpEL expressions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework:spring-expressionall versions5.3.39org.springframework:spring-expression:5.3.39

Affected Products

3 products · 5 configurations
Application
active iq unified managernetapp
all
Application
oncommand insightnetapp
all
Application
spring frameworkvmware
≥ 5.3.0 && < 5.3.39
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework:spring-expression, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework:spring-expression to 5.3.39 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-38808 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Moderate impact: CVE-2024-38808 affects certain Red Hat products containing the spring-expression component when an application evaluates user-supplied Spring Expression Language (SpEL) expressions. A maliciously crafted expression can cause uncontrolled CPU usage and denial of service. Red Hat's CVSS is 5.9…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
Source: Red Hat security advisory for CVE-2024-38808 (CC BY 4.0)
ProductFixed inAdvisory
OCP-Tools-4.12-RHEL-8jenkins-0:2.462.3.1730119132-3.el8RHSA-2024:8886
OCP-Tools-4.13-RHEL-8jenkins-0:2.462.3.1729839924-3.el8RHSA-2024:8887
OCP-Tools-4.14-RHEL-8jenkins-0:2.462.3.1729839727-3.el8RHSA-2024:8885
OCP-Tools-4.15-RHEL-8jenkins-0:2.462.3.1729837947-3.el8RHSA-2024:8884
Red Hat build of Apache Camel 4.4.2 for Spring Bootspring-expressionRHSA-2024:6508

Frequently Asked Questions

In Spring Framework versions 5.3.0 - 5.3.38 and older unsupported versions, it is possible for a user to provide a specially crafted Spring Expression Language (SpEL) expression that may cause a denial of service (DoS) condition. Older, unsupported versions are also affected. Specifically, an application is vulnerable when the following is true: * The application evaluates user-supplied SpEL expressions.
O3 Security · Impact-Aware SCA

Is CVE-2024-38808 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2024-38808: spring-expression DoS — Fixed in 5.3.39