NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
LOW severity

CVE-2026-41852 — spring-expression

LOW

CVE-2026-41852 is a low-severity (CVSS 3.7) CWE-863 vulnerability in org.springframework:spring-expression. A fix is available for org.springframework:spring-expression — see the affected versions and patch details below.

Spring Framework Arbitrary Method Invocation in SpEL Expressions

Published
Updated
Affected
4 pkgs
Patched
2 / 4
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-41852.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk-0.08%
Lower risk than most CVEs7th percentile — riskier than 7% of all scored CVEsHighest risk
0.00%0.25%0.51%0.76%0.2%0.2%0.2%0.3%0.2%Jul 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.springframework:spring-expression☕org.springframework:spring-expression☕org.springframework:spring-expression☕org.springframework:spring-expression

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability in Spring Expression Language (SpEL) evaluation logic allows for arbitrary zero-argument method invocation, even within restricted or read-only contexts, which may allow an attacker to invoke unintended application logic.

Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

Affected Packages

4 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework:spring-expression≥ 7.0.0&&< 7.0.87.0.8org.springframework:spring-expression:7.0.8
☕Mavenorg.springframework:spring-expression≥ 6.2.0&&< 6.2.196.2.19org.springframework:spring-expression:6.2.19
☕Mavenorg.springframework:spring-expression≥ 6.1.0No fix
☕Mavenorg.springframework:spring-expressionall versionsNo fix

Affected Products

1 product · 4 configurations
Application
spring frameworkvmware
≥ 7.0.0 && < 7.0.7.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework:spring-expression, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework:spring-expression to 7.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-41852 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

A vulnerability in Spring Expression Language (SpEL) evaluation logic allows for arbitrary zero-argument method invocation, even within restricted or read-only contexts, which may allow an attacker to invoke unintended application logic. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.
O3 Security · Impact-Aware SCA

Is CVE-2026-41852 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-41852: spring-expression — Fixed in 7.0.8