NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-22950 — spring-expression

MEDIUMFix: spring-projects/spring-framework@83ac659

CVE-2022-22950 is a medium-severity (CVSS 6.5) CWE-770 vulnerability in org.springframework:spring-expression. EPSS puts its 30-day exploitation probability at 36.9% (99th percentile). A fix is available for org.springframework:spring-expression — see the affected versions and patch details below.

Allocation of Resources Without Limits or Throttling in Spring Framework

Also known asGHSA-558x-2xjg-6232
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-22950.

EPSS Exploitation Probability

via FIRST.org ↗
36.9%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.00%15.6%31.2%46.7%4.1%36.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.springframework:spring-expression☕org.springframework:spring-expression

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Spring Framework versions 5.3.0 - 5.3.16, 5.2.0.RELEASE - 5.2.19.RELEASE, and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial of service condition.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework:spring-expression≥ 5.3.0&&< 5.3.175.3.17org.springframework:spring-expression:5.3.17
☕Mavenorg.springframework:spring-expressionall versions5.2.20.RELEASEorg.springframework:spring-expression:5.2.20.RELEASE

Affected Products

1 product · 2 configurations
Application
spring frameworkvmware
≥ 5.3.0 && < 5.3.17
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework:spring-expression, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework:spring-expression to 5.3.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-22950 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Fuse 7.11spring-expressionRHSA-2022:5532
Red Hat Virtualization Engine 4.4ovirt-dependencies-0:4.5.2-1.el8evRHSA-2022:5555
RHPAM 7.13.0 asyncspring-expressionRHSA-2022:5903
Text-Only RHOARspring-expressionRHSA-2022:8761

Frequently Asked Questions

In Spring Framework versions 5.3.0 - 5.3.16, 5.2.0.RELEASE - 5.2.19.RELEASE, and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial of service condition.
O3 Security · Impact-Aware SCA

Is CVE-2022-22950 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-22950: spring-expression DoS — Fixed in 5.3.17