CVE-2024-38286 is a high-severity (CVSS 8.6) CWE-770 vulnerability in org.apache.tomcat:tomcat-coyote. A fix is available for org.apache.tomcat:tomcat-coyote — see the affected versions and patch details below.
Apache Tomcat: Denial of Service
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-38286.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core+2 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.13 through 9.0.89.
The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.35 through 8.5.100 and 7.0.92 through 7.0.109. Other EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M21, 10.1.25, or 9.0.90, which fixes the issue.
Apache Tomcat, under certain configurations on any platform, allows an attacker to cause an OutOfMemoryError by abusing the TLS handshake process.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 11.0.0-M1&&< 11.0.0-M21 | 11.0.0-M21org.apache.tomcat:tomcat-coyote:11.0.0-M21 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 10.1.0-M1&&< 10.1.25 | 10.1.25org.apache.tomcat:tomcat-coyote:10.1.25 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 9.0.13&&< 9.0.90 | 9.0.90org.apache.tomcat:tomcat-coyote:9.0.90 |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 8.5.35 | No fix |
| ☕Maven | org.apache.tomcat:tomcat-coyote | ≥ 7.0.92 | No fix |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 11.0.0-M1&&< 11.0.0-M21 | 11.0.0-M21org.apache.tomcat.embed:tomcat-embed-core:11.0.0-M21 |
Affected Products
tomcatapacheontap toolsnetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-coyote, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-coyote to 11.0.0-M21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-38286 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
CVE-2024-38286 represents an important security issue due to its potential to cause an `OutOfMemoryError` through the exploitation of the TLS handshake process in Apache Tomcat. This vulnerability specifically impacts configurations using TLS 1.3, which is increasingly adopted for secure communications. The ability…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-38286 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | tomcat9-1:9.0.110-2.el10_2 | RHSA-2026:18536 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | tomcat9-1:9.0.120-1.el10_0 | RHSA-2026:67163 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.87-1.el8_10.2 | RHSA-2024:5694 |
| Red Hat Enterprise Linux 8.2 Advanced Update Support | pki-deps:10.6-8020020241017135048.4cda2c84 | RHSA-2024:8567 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support | pki-deps:10.6-8040020241017141927.522a0ee4 | RHSA-2024:8497 |
| Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support | pki-deps:10.6-8060020241017143140.ad008a3a | RHSA-2024:8572 |
| Red Hat Enterprise Linux 8.8 Extended Update Support | tomcat-1:9.0.87-1.el8_8.3 | RHSA-2024:5695 |
| Red Hat Enterprise Linux 8.8 Extended Update Support | pki-core:10.6-8080020241014201334.693a3987 | RHSA-2024:8543 |
Frequently Asked Questions
Is CVE-2024-38286 in your dependencies?
Find it across Maven, including transitive dependencies.