CVE-2024-32463 is a high-severity (CVSS 7.1) Cross-site Scripting (XSS) vulnerability in phlex. A fix is available for phlex — see the affected versions and patch details below.
phlex makes Cross-site Scripting (XSS) possible due to improper sanitisation of `href` attributes on `<a>` tags
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-32463.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phlex💎phlex💎phlex💎phlex💎phlex💎phlex💎phlexReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Summary
There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data.
Our filter to detect and prevent the use of the javascript: URL scheme in the href attribute of an <a> tag could be bypassed with tab \t or newline \n characters between the characters of the protocol, e.g. java\tscript:.
Impact
If you render an <a> tag with an href attribute set to a user-provided link, that link could potentially execute JavaScript when clicked by another user.
a(href: user_profile) { "Profile" }
Mitigation
The best way to mitigate this vulnerability is to update to one of the following versions:
Workarounds
Configuring a Content Security Policy that does not allow unsafe-inline would effectively prevent this vulnerability from being exploited.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | phlex | ≥ 1.10.0&&< 1.10.1 | 1.10.1bundle update phlex --conservative |
| 💎RubyGems | phlex | ≥ 1.9.0&&< 1.9.2 | 1.9.2bundle update phlex --conservative |
| 💎RubyGems | phlex | ≥ 1.8.0&&< 1.8.3 | 1.8.3bundle update phlex --conservative |
| 💎RubyGems | phlex | ≥ 1.7.0&&< 1.7.2 | 1.7.2bundle update phlex --conservative |
| 💎RubyGems | phlex | ≥ 1.6.0&&< 1.6.3 | 1.6.3bundle update phlex --conservative |
| 💎RubyGems | phlex | ≥ 1.5.0&&< 1.5.3 | 1.5.3bundle update phlex --conservative |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phlex, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phlex to 1.10.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-32463 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-32463 in your dependencies?
Find it across RubyGems, including transitive dependencies.