Phlex XSS protection bypass via attribute splatting, dynamic tags, and href valuesGHSA-w67g-2h6v-vjgq
HIGHFix: yippee-fun/phlex@1d85da4GHSA-w67g-2h6v-vjgq is a high-severity (CVSS 7.1) vulnerability in phlex. A fix is available for phlex — see the affected versions and patch details below.
Real-World Exposure
phlex💎phlex💎phlex💎phlex💎phlex💎phlexReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Impact
During a security audit conducted with Claude Opus 4.6 and GPT-5.3-Codex, we identified three specific ways to bypass the XSS (cross-site-scripting) protection built into Phlex.
- The first bypass could happen if user-provided attributes with string keys were splatted into HTML tag, e.g.
div(**user_attributes). - The second bypass could happen if user-provided tag names were passed to the
tagmethod, e.g.tag(some_tag_name_from_user). - The third bypass could happen if user’s links were passed to
hrefattributes, e.g.a(href: user_provided_link).
All three of these patterns are meant to be safe and all have now been patched.
Patches
Phlex has patched all three issues and introduced new tests that run against Safari, Firefox and Chrome.
The patched versions are:
Phlex has also patched the main branch in GitHub.
Workarounds
If a project uses a secure CSP (content security policy) or if the application doesn’t use any of the above patterns, it is not at risk.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | phlex | ≥ 2.4.0.beta1&&< 2.4.1 | 2.4.1bundle update phlex --conservative |
| 💎RubyGems | phlex | ≥ 2.3.0&&< 2.3.2 | 2.3.2bundle update phlex --conservative |
| 💎RubyGems | phlex | ≥ 2.2.0&&< 2.2.2 | 2.2.2bundle update phlex --conservative |
| 💎RubyGems | phlex | ≥ 2.1.0&&< 2.1.3 | 2.1.3bundle update phlex --conservative |
| 💎RubyGems | phlex | ≥ 2.0.0.beta1&&< 2.0.2 | 2.0.2bundle update phlex --conservative |
| 💎RubyGems | phlex | all versions | 1.11.1bundle update phlex --conservative |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phlex, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phlex to 2.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w67g-2h6v-vjgq is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-w67g-2h6v-vjgq in your dependencies?
Find it across RubyGems, including transitive dependencies.