NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2024-28199 — phlex

HIGHFix: phlex-ruby/phlex@aa50c60

CVE-2024-28199 is a high-severity (CVSS 7.1) Cross-site Scripting (XSS) vulnerability in phlex. A fix is available for phlex — see the affected versions and patch details below.

Cross-site Scripting (XSS) possible with maliciously formed HTML attribute names and values in Phlex

Also known asGHSA-242p-4v39-2v8g
Published
Updated
Affected
10 pkgs
Patched
10 / 10
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-28199.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs49th percentile — riskier than 49% of all scored CVEsHighest risk
0.10%0.75%1.40%2.04%1.5%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

10 pkgs affected
💎phlex💎phlex💎phlex💎phlex💎phlex💎phlex💎phlex💎phlex+2 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. This was due to improper case-sensitivity in the code that was meant to prevent these attacks.

Impact

If you render an <a> tag with an href attribute set to a user-provided link, that link could potentially execute JavaScript when clicked by another user.

a(href: user_profile) { "Profile" }

If you splat user-provided attributes when rendering any HTML or SVG tag, malicious event attributes could be included in the output, executing JavaScript when the events are triggered by another user.

h1(**JSON.parse(user_attributes))

Patches

Patches are available on RubyGems for all 1.x minor versions. The patched versions are:

If you are on main, it has been patched since aa50c60

Workarounds

Configuring a Content Security Policy that does not allow unsafe-inline would effectively prevent this vulnerability from being exploited.

References

In addition to upgrading to a patched version of Phlex, we strongly recommend configuring a Content Security Policy header that does not allow unsafe-inline. Here’s how you can configure a Content Security Policy header in Rails. https://guides.rubyonrails.org/security.html#content-security-policy-header

Affected Packages

10 total 10 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsphlex≥ 1.9.0&&< 1.9.11.9.1bundle update phlex --conservative
💎RubyGemsphlex≥ 1.8.0&&< 1.8.21.8.2bundle update phlex --conservative
💎RubyGemsphlex≥ 1.7.0&&< 1.7.11.7.1bundle update phlex --conservative
💎RubyGemsphlex≥ 1.6.0&&< 1.6.21.6.2bundle update phlex --conservative
💎RubyGemsphlex≥ 1.5.0&&< 1.5.21.5.2bundle update phlex --conservative
💎RubyGemsphlex≥ 1.4.0&&< 1.4.11.4.1bundle update phlex --conservative

Affected Products

1 product · 7 configurations
Application
phlexphlex
≥ 1.3.0 && < 1.3.3
4 versions
1.1.01.4.01.7.01.9.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phlex, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phlex to 1.9.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-28199 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. This was due to improper case-sensitivity in the code that was meant to prevent these attacks. ### Impact If you render an `<a>` tag with an `href` attribute set to a user-provided link, that link could potentially execute JavaScript when clicked by another user. ```ruby a(href: user_profile) { "Profile" } ``` If you splat user-provided attributes when rendering any HTML or SVG tag, malicious event attributes could be included in the output, executing JavaScript when the e
O3 Security · Impact-Aware SCA

Is CVE-2024-28199 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2024-28199: phlex XSS — Fixed in 1.9.1