NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2024-27136 — jspwiki-main

MEDIUM

CVE-2024-27136 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.jspwiki:jspwiki-main. EPSS puts its 30-day exploitation probability at 60.8% (99th percentile). A fix is available for org.apache.jspwiki:jspwiki-main — see the affected versions and patch details below.

Apache JSPWiki: Cross-site scripting vulnerability on upload page

Also known asGHSA-36gf-vpj2-j42w
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-27136.

EPSS Exploitation Probability

via FIRST.org ↗
60.8%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
47.5%53.0%58.4%63.9%50.6%60.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.jspwiki:jspwiki-main

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

XSS in Upload page in Apache JSPWiki 2.12.1 and priors allows the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.2 or later.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.jspwiki:jspwiki-mainall versions2.12.2org.apache.jspwiki:jspwiki-main:2.12.2

Affected Products

1 product · 1 configurations
Application
jspwikiapache
< 2.12.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.jspwiki:jspwiki-main, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.jspwiki:jspwiki-main to 2.12.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-27136 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

XSS in Upload page in Apache JSPWiki 2.12.1 and priors allows the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.2 or later.
O3 Security · Impact-Aware SCA

Is CVE-2024-27136 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2024-27136: jspwiki-main XSS — Fixed in 2.12.2