NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-27166 — jspwiki-main

MEDIUM

CVE-2022-27166 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.jspwiki:jspwiki-main. EPSS puts its 30-day exploitation probability at 86.2% (100th percentile). A fix is available for org.apache.jspwiki:jspwiki-main — see the affected versions and patch details below.

XSS vulnerability on XHRHtml2Markup.jsp in JSPWiki 2.11.2

Also known asGHSA-2fxf-qj94-3f83
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 25, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
86.2%probability of exploitation in next 30 days
Very High Risk+0.41%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%8.6%86.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.jspwiki:jspwiki-main

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A carefully crafted request on XHRHtml2Markup.jsp could trigger an XSS vulnerability on Apache JSPWiki up to and including 2.11.2, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Version 2.11.3 contains a fix for the problem

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.jspwiki:jspwiki-mainall versions2.11.3org.apache.jspwiki:jspwiki-main:2.11.3

Affected Products

1 product · 1 configurations
Application
jspwikiapache
< 2.11.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.jspwiki:jspwiki-main, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.jspwiki:jspwiki-main to 2.11.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-27166 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A carefully crafted request on XHRHtml2Markup.jsp could trigger an XSS vulnerability on Apache JSPWiki up to and including 2.11.2, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Version 2.11.3 contains a fix for the problem
O3 Security · Impact-Aware SCA

Is CVE-2022-27166 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-27166: jspwiki-main XSS — Fixed in 2.11.3