CVE-2022-28731 — jspwiki-main
MEDIUMCVE-2022-28731 is a medium-severity (CVSS 6.5) Cross-Site Request Forgery (CSRF) vulnerability in org.apache.jspwiki:jspwiki-main. EPSS puts its 30-day exploitation probability at 58.7% (99th percentile). A fix is available for org.apache.jspwiki:jspwiki-main — see the affected versions and patch details below.
Apache JSPWiki CSRF in UserPreferences.jsp
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.jspwiki:jspwiki-mainReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A carefully crafted request on UserPreferences.jsp could trigger an CSRF vulnerability on Apache JSPWiki before 2.11.3, which could allow the attacker to modify the email associated with the attacked account, and then a reset password request from the login page.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.jspwiki:jspwiki-main | all versions | 2.11.3org.apache.jspwiki:jspwiki-main:2.11.3 |
Affected Products
jspwikiapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.jspwiki:jspwiki-main, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.jspwiki:jspwiki-main to 2.11.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-28731 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-28731 in your dependencies?
Find it across Maven, including transitive dependencies.