CVE-2023-45860 is a medium-severity (CVSS 6.5) SQL Injection vulnerability in com.hazelcast:hazelcast. A fix is available for com.hazelcast:hazelcast — see the affected versions and patch details below.
Hazelcast Platform permission checking in CSV File Source connector
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-45860.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.hazelcast:hazelcast☕com.hazelcast:hazelcast-enterprise☕com.hazelcast:hazelcast-enterprise☕com.hazelcast:hazelcast-enterprise☕com.hazelcast:hazelcast☕com.hazelcast:hazelcastReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
In Hazelcast Platform through 5.3.4, a security issue exists within the SQL mapping for the CSV File Source connector. This issue arises from inadequate permission checking, which could enable unauthorized clients to access data from files stored on a member's filesystem.
Patches
Fix versions: 5.3.5, 5.4.0-BETA-1
Workaround
Disabling Hazelcast Jet processing engine in Hazelcast member configuration workarounds the issue. As a result SQL and Jet jobs won't work.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.hazelcast:hazelcast | ≥ 5.3.0&&< 5.3.5 | 5.3.5com.hazelcast:hazelcast:5.3.5 |
| ☕Maven | com.hazelcast:hazelcast-enterprise | ≥ 5.3.0&&< 5.3.5 | 5.3.5com.hazelcast:hazelcast-enterprise:5.3.5 |
| ☕Maven | com.hazelcast:hazelcast-enterprise | ≥ 5.2.0&&< 5.2.5 | 5.2.5com.hazelcast:hazelcast-enterprise:5.2.5 |
| ☕Maven | com.hazelcast:hazelcast-enterprise | all versions | No fix |
| ☕Maven | com.hazelcast:hazelcast | ≥ 5.2.0&&< 5.2.5 | 5.2.5com.hazelcast:hazelcast:5.2.5 |
| ☕Maven | com.hazelcast:hazelcast | all versions | No fix |
Affected Products
hazelcasthazelcastDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.hazelcast:hazelcast, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.hazelcast:hazelcast to 5.3.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-45860 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Disabling the Hazelcast Jet processing engine in the Hazelcast member configuration is a workaround for the issue. As a result, SQL and Jet jobs won't work.Source: Red Hat security advisory for CVE-2023-45860 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2023-45860 in your dependencies?
Find it across Maven, including transitive dependencies.