CVE-2023-33265 — hazelcast
HIGHCVE-2023-33265 is a high-severity (CVSS 7.6) CWE-862 vulnerability in com.hazelcast:hazelcast. A fix is available for com.hazelcast:hazelcast — see the affected versions and patch details below.
Hazelcast Executor Services don't check client permissions properly
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-33265.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.hazelcast:hazelcast☕com.hazelcast:hazelcast☕com.hazelcast:hazelcast☕com.hazelcast:hazelcast-enterprise☕com.hazelcast:hazelcast-enterprise☕com.hazelcast:hazelcast-enterpriseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
In Hazelcast Platform, 5.0 through 5.0.4, 5.1 through 5.1.6, and 5.2 through 5.2.3, and Hazelcast IMDG (all versions up to 4.2.z), Executor Services don't check client permissions properly, allowing authenticated users to execute tasks on members without the required permissions granted.
Patches
Fix versions: 5.3.0, 5.2.4, 5.1.7, 5.0.5
Workarounds
Users are only affected when they already use executor services (i.e., an instance exists as a distributed data structure).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.hazelcast:hazelcast | ≥ 5.2.0&&< 5.2.4 | 5.2.4com.hazelcast:hazelcast:5.2.4 |
| ☕Maven | com.hazelcast:hazelcast | ≥ 5.1.0&&< 5.1.7 | 5.1.7com.hazelcast:hazelcast:5.1.7 |
| ☕Maven | com.hazelcast:hazelcast | all versions | 5.0.5com.hazelcast:hazelcast:5.0.5 |
| ☕Maven | com.hazelcast:hazelcast-enterprise | ≥ 5.2.0&&< 5.2.4 | 5.2.4com.hazelcast:hazelcast-enterprise:5.2.4 |
| ☕Maven | com.hazelcast:hazelcast-enterprise | ≥ 5.1.0&&< 5.1.7 | 5.1.7com.hazelcast:hazelcast-enterprise:5.1.7 |
| ☕Maven | com.hazelcast:hazelcast-enterprise | all versions | 5.0.5com.hazelcast:hazelcast-enterprise:5.0.5 |
Affected Products
hazelcasthazelcastimdghazelcastDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.hazelcast:hazelcast, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.hazelcast:hazelcast to 5.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-33265 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-33265 in your dependencies?
Find it across Maven, including transitive dependencies.