NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2022-36437 — hazelcast

CRITICAL

CVE-2022-36437 is a critical-severity (CVSS 9.1) CWE-384 vulnerability in com.hazelcast:hazelcast. A fix is available for com.hazelcast:hazelcast — see the affected versions and patch details below.

Hazelcast connection caching

Also known asGHSA-c5hg-mr8r-f6jp
Published
Updated
Affected
14 pkgs
Patched
12 / 14
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-36437.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.53%1.06%1.59%0.4%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

14 pkgs affected
☕com.hazelcast:hazelcast☕com.hazelcast:hazelcast☕com.hazelcast:hazelcast☕com.hazelcast:hazelcast☕com.hazelcast:hazelcast☕com.hazelcast:hazelcast☕com.hazelcast.jet:hazelcast-jet☕com.hazelcast.jet:hazelcast-jet-enterprise+6 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The Connection handler in Hazelcast and Hazelcast Jet allows an unauthenticated, remote attacker to access and manipulate data in the cluster with another authenticated connection's identity. The affected Hazelcast versions are through 3.12.12, 4.0.6, 4.1.9, 4.2.5, 5.0.3, and 5.1.2. The affected Hazelcast Jet versions are through 4.5.3.

Patches

Hazelcast Jet (and Enterprise) 4.5.4. Hazelcast IMDG (and Enterprise)3.12.13 Hazelcast IMDG (and Enterprise) 4.1.10 Hazelcast IMDG (and Enterprise) 4.2.6 Hazelcast Platform (and Enterprise) 5.1.3

Workarounds

There is no known workaround, but setups with TLS and mutual authentication enabled significantly lowers the exploitation risk.

References

https://support.hazelcast.com/s/article/Security-Advisory-for-CVE-2022-36437

Affected Packages

14 total 12 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.hazelcast:hazelcastall versions3.12.13com.hazelcast:hazelcast:3.12.13
☕Mavencom.hazelcast:hazelcast≥ 4.0No fix
☕Mavencom.hazelcast:hazelcast≥ 4.1&&< 4.1.104.1.10com.hazelcast:hazelcast:4.1.10
☕Mavencom.hazelcast:hazelcast≥ 4.2&&< 4.2.64.2.6com.hazelcast:hazelcast:4.2.6
☕Mavencom.hazelcast:hazelcast≥ 5.0&&< 5.0.45.0.4com.hazelcast:hazelcast:5.0.4
☕Mavencom.hazelcast:hazelcast≥ 5.1&&< 5.1.35.1.3com.hazelcast:hazelcast:5.1.3

Affected Products

2 products · 12 configurations
Application
hazelcasthazelcast
≥ 5.1.0 && < 5.1.3
range
Application
hazelcast-jethazelcast
< 4.5.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.hazelcast:hazelcast, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.hazelcast:hazelcast to 3.12.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36437 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatCritical

Red Hat Integration - Camel Quarkus Extensions: Hazelcast is contained in camel-quarkus-hazelcast but it does not affect any supported component. This package is community support only. Hence the low impact for Camel Quarkus Extension.

ProductFixed inAdvisory
Red Hat Fuse 7.11.1.P1hazelcastRHSA-2023:0483
Red Hat Fuse 7.12see advisoryRHSA-2023:3954
Red Hat Fuse on EAP 7.11.1.P1hazelcastRHSA-2023:0661

Frequently Asked Questions

### Impact The Connection handler in Hazelcast and Hazelcast Jet allows an unauthenticated, remote attacker to access and manipulate data in the cluster with another authenticated connection's identity. The affected Hazelcast versions are through 3.12.12, 4.0.6, 4.1.9, 4.2.5, 5.0.3, and 5.1.2. The affected Hazelcast Jet versions are through 4.5.3. ### Patches Hazelcast Jet (and Enterprise) 4.5.4. Hazelcast IMDG (and Enterprise)3.12.13 Hazelcast IMDG (and Enterprise) 4.1.10 Hazelcast IMDG (and Enterprise) 4.2.6 Hazelcast Platform (and Enterprise) 5.1.3 ### Workarounds There is no known workar
O3 Security · Impact-Aware SCA

Is CVE-2022-36437 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-36437: hazelcast — Fixed in 3.12.13