NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2016-10750 — hazelcast

HIGHFix: hazelcast/hazelcast#12230

CVE-2016-10750 is a high-severity (CVSS 8.1) Deserialization of Untrusted Data vulnerability in com.hazelcast:hazelcast. A fix is available for com.hazelcast:hazelcast — see the affected versions and patch details below.

Deserialization of Untrusted Data in Hazelcast

Also known asGHSA-jv65-pf7v-f7p8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
2.32%3.03%3.74%4.45%2.8%4.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.hazelcast:hazelcast

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Hazelcast before 3.11, the cluster join procedure is vulnerable to remote code execution via Java deserialization. If an attacker can reach a listening Hazelcast instance with a crafted JoinRequest, and vulnerable classes exist in the classpath, the attacker can run arbitrary code.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.hazelcast:hazelcastall versions3.11com.hazelcast:hazelcast:3.11

Affected Products

1 product · 1 configurations
Application
hazelcasthazelcast
< 3.11
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.hazelcast:hazelcast, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.hazelcast:hazelcast to 3.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-10750 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

The module vertx-hazelcast is not supported in Red Hat OpenShift Application Runtimes (RHOAR) products.

ProductFixed inAdvisory
Red Hat Fuse 7.4.0hazelcastRHSA-2019:2413

Frequently Asked Questions

In Hazelcast before 3.11, the cluster join procedure is vulnerable to remote code execution via Java deserialization. If an attacker can reach a listening Hazelcast instance with a crafted JoinRequest, and vulnerable classes exist in the classpath, the attacker can run arbitrary code.
O3 Security · Impact-Aware SCA

Is CVE-2016-10750 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-10750: hazelcast RCE — Fixed in 3.11