CVE-2023-37899 is a high-severity (CVSS 7.5) CWE-754 vulnerability in @feathersjs/socketio. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for @feathersjs/socketio — see the affected versions and patch details below.
feathersjs socket handler allows abusing implicit toString
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-37899.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@feathersjs/socketionpm@feathersjs/transport-commonsnpmDescription
Impact
Feathers socket handler did not catch invalid string conversion errors like:
const message = `${{ toString: '' }}`
Causing the NodeJS process to crash when sending an unexpected Socket.io message like
socket.emit('find', { toString: '' })
Patches
A fix has been released in
v5.0.8via #3241v4.5.18via #3242
Workarounds
Since it is in the core Socket handling code upgrading to the latest version is necessary.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @feathersjs/socketio | all versions | 4.5.18npm install @feathersjs/socketio@4.5.18 |
| 📦npm | @feathersjs/socketio | ≥ 5.0.0&&< 5.0.8 | 5.0.8npm install @feathersjs/socketio@5.0.8 |
| 📦npm | @feathersjs/transport-commons | all versions | 4.5.18npm install @feathersjs/transport-commons@4.5.18 |
| 📦npm | @feathersjs/transport-commons | ≥ 5.0.0&&< 5.0.8 | 5.0.8npm install @feathersjs/transport-commons@5.0.8 |
Affected Products
feathersfeathersjsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @feathersjs/socketio, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @feathersjs/socketio to 4.5.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-37899 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-37899 in your dependencies?
Find it across npm, including transitive dependencies.