CVE-2023-34104 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in fast-xml-parser. A fix is available for fast-xml-parser — see the affected versions and patch details below.
Regex Injection via Doctype Entities
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
fast-xml-parsernpmDescription
fast-xml-parser is an open source, pure javascript xml parser. fast-xml-parser allows special characters in entity names, which are not escaped or sanitized. Since the entity name is used for creating a regex for searching and replacing entities in the XML body, an attacker can abuse it for denial of service (DoS) attacks. By crafting an entity name that results in an intentionally bad performing regex and utilizing it in the entity replacement step of the parser, this can cause the parser to stall for an indefinite amount of time. This problem has been resolved in v4.2.4. Users are advised to upgrade. Users unable to upgrade should avoid using DOCTYPE parsing by setting the processEntities: false option.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | fast-xml-parser | ≥ 4.1.3&&< 4.2.4 | 4.2.4npm install fast-xml-parser@4.2.4 |
Affected Products
fast-xml-parsernaturalintelligenceDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fast-xml-parser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update fast-xml-parser to 4.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-34104 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| MTA-6.2-RHEL-9 | mta/mta-ui-rhel9:6.2.0-17 | RHSA-2023:4627 |
Frequently Asked Questions
Is CVE-2023-34104 in your dependencies?
Find it across npm, including transitive dependencies.