CVE-2023-32732 is a medium-severity (CVSS 5.3) CWE-440 vulnerability in io.grpc:grpc-protobuf. A fix is available for io.grpc:grpc-protobuf — see the affected versions and patch details below.
Denial-of-Service in gRPC
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-32732.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.grpc:grpc-protobuf☕io.grpc:grpc-protobuf🐍grpcio🐍grpcio💎grpc💎grpcReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.
Description
gRPC contains a vulnerability whereby a client can cause a termination of connection between a HTTP2 proxy and a gRPC server: a base64 encoding error for -bin suffixed headers will result in a disconnection by the gRPC server, but is typically allowed by HTTP2 proxies. We recommend upgrading beyond the commit in https://github.com/grpc/grpc/pull/32309 https://www.google.com/url
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.grpc:grpc-protobuf | ≥ 1.53.0&&< 1.53.1 | 1.53.1io.grpc:grpc-protobuf:1.53.1 |
| ☕Maven | io.grpc:grpc-protobuf | ≥ 1.54.0&&< 1.54.2 | 1.54.2io.grpc:grpc-protobuf:1.54.2 |
| 🐍PyPI | grpcio | ≥ 1.53.0&&< 1.53.1 | 1.53.1pip install --upgrade 'grpcio==1.53.1' |
| 🐍PyPI | grpcio | ≥ 1.54.0&&< 1.54.2 | 1.54.2pip install --upgrade 'grpcio==1.54.2' |
| 💎RubyGems | grpc | ≥ 1.53.0&&< 1.53.1 | 1.53.1bundle update grpc --conservative |
| 💎RubyGems | grpc | ≥ 1.54.0&&< 1.54.2 | 1.54.2bundle update grpc --conservative |
Affected Products
fedorafedoraprojectgrpcgrpcDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.grpc:grpc-protobuf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.grpc:grpc-protobuf to 1.53.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-32732 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-32732 in your dependencies?
Find it across Maven, PyPI, RubyGems, including transitive dependencies.