NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven🐍 PyPI💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2023-1428 — grpc-protobuf

HIGHFix: grpc/grpc@2485fa9

CVE-2023-1428 is a high-severity (CVSS 7.5) Reachable Assertion vulnerability in io.grpc:grpc-protobuf. A fix is available for io.grpc:grpc-protobuf — see the affected versions and patch details below.

Denial-of-Service in gRPC

Also known asGHSA-6628-q6j9-w8vgPYSEC-2026-1425
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-1428.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs35th percentile — riskier than 35% of all scored CVEsHighest risk
0.00%0.30%0.61%0.91%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕io.grpc:grpc-protobuf🐍grpcio💎grpc

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI, RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

There exists an vulnerability causing an abort() to be called in gRPC.  The following headers cause gRPC's C++ implementation to abort() when called via http2:

te: x (x != trailers)

:scheme: x (x != http, https)

grpclb_client_stats: x (x == anything)

On top of sending one of those headers, a later header must be sent that gets the total header size past 8KB. We recommend upgrading past git commit 2485fa94bd8a723e5c977d55a3ce10b301b437f8 or v1.53 and above.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.grpc:grpc-protobuf≥ 1.51.0&&< 1.53.01.53.0io.grpc:grpc-protobuf:1.53.0
🐍PyPIgrpcio≥ 1.51.0&&< 1.53.01.53.0pip install --upgrade 'grpcio==1.53.0'
💎RubyGemsgrpc≥ 1.51.0&&< 1.53.01.53.0bundle update grpc --conservative

Affected Products

1 product · 1 configurations
Application
grpcgrpc
≥ 1.51.0 && < 1.53.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.grpc:grpc-protobuf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.grpc:grpc-protobuf to 1.53.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-1428 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This vulnerability is specific to the C++, Python and Ruby implementations of gRPC prior to the 1.53 release. The gRPC library was packaged with Openshift via the Kuryr component. However, Kuryr was never configured to run code using the gRPC library and has since been removed.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2023-1428 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 9rhc-worker-playbook-0:0.1.10-1.el9_5RHSA-2024:10761

Frequently Asked Questions

There exists an vulnerability causing an abort() to be called in gRPC.  The following headers cause gRPC's C++ implementation to abort() when called via http2: te: x (x != trailers) :scheme: x (x != http, https) grpclb_client_stats: x (x == anything) On top of sending one of those headers, a later header must be sent that gets the total header size past 8KB. We recommend upgrading past git commit 2485fa94bd8a723e5c977d55a3ce10b301b437f8 or v1.53 and above.
O3 Security · Impact-Aware SCA

Is CVE-2023-1428 in your dependencies?

Find it across Maven, PyPI, RubyGems, including transitive dependencies.

CVE-2023-1428: grpc-protobuf — Fixed in 1.53.0