CVE-2023-31469 — streampipes-parent
HIGHCVE-2023-31469 is a high-severity (CVSS 8.8) Improper Privilege Management vulnerability in org.apache.streampipes:streampipes-parent. A fix is available for org.apache.streampipes:streampipes-parent — see the affected versions and patch details below.
Apache StreamPipes: Privilege escalation through non-admin user
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-31469.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.streampipes:streampipes-parentReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A REST interface in Apache StreamPipes (versions 0.69.0 to 0.91.0) was not properly restricted to admin-only access. This allowed a non-admin user with valid login credentials to elevate privileges beyond the initially assigned roles. The issue is resolved by upgrading to StreamPipes 0.92.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.streampipes:streampipes-parent | ≥ 0.69.0&&< 0.92.0 | 0.92.0org.apache.streampipes:streampipes-parent:0.92.0 |
Affected Products
streampipesapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.streampipes:streampipes-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.streampipes:streampipes-parent to 0.92.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-31469 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2023-31469 in your dependencies?
Find it across Maven, including transitive dependencies.