CVE-2024-31979 is a high-severity (CVSS 7.5) Server-Side Request Forgery (SSRF) vulnerability in org.apache.streampipes:streampipes-parent. A fix is available for org.apache.streampipes:streampipes-parent — see the affected versions and patch details below.
Apache StreamPipes: Possibility of SSRF in pipeline element installation process
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-31979.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.streampipes:streampipes-parent🐍streampipesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache StreamPipes during installation process of pipeline elements. Previously, StreamPipes allowed users to configure custom endpoints from which to install additional pipeline elements. These endpoints were not properly validated, allowing an attacker to get StreamPipes to send an HTTP GET request to an arbitrary address. This issue affects Apache StreamPipes: through 0.93.0.
Users are recommended to upgrade to version 0.95.0, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.streampipes:streampipes-parent | all versions | 0.95.0org.apache.streampipes:streampipes-parent:0.95.0 |
| 🐍PyPI | streampipes | all versions | 0.95.0pip install --upgrade 'streampipes==0.95.0' |
Affected Products
streampipesapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.streampipes:streampipes-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.streampipes:streampipes-parent to 0.95.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-31979 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is CVE-2024-31979 in your dependencies?
Find it across Maven, PyPI, including transitive dependencies.