CVE-2024-30471 — streampipes-parent
MEDIUMCVE-2024-30471 is a medium-severity (CVSS 5.3) CWE-367 vulnerability in org.apache.streampipes:streampipes-parent. A fix is available for org.apache.streampipes:streampipes-parent — see the affected versions and patch details below.
Apache StreamPipes: Potential creation of multiple identical accounts
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-30471.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.streampipes:streampipes-parent🐍streampipesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability in Apache StreamPipes in user self-registration. This allows an attacker to potentially request the creation of multiple accounts with the same email address until the email address is registered, creating many identical users and corrupting StreamPipe's user management. This issue affects Apache StreamPipes: through 0.93.0.
Users are recommended to upgrade to version 0.95.0, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.streampipes:streampipes-parent | all versions | 0.95.0org.apache.streampipes:streampipes-parent:0.95.0 |
| 🐍PyPI | streampipes | all versions | 0.95.0pip install --upgrade 'streampipes==0.95.0' |
Affected Products
streampipesapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.streampipes:streampipes-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.streampipes:streampipes-parent to 0.95.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-30471 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-30471 in your dependencies?
Find it across Maven, PyPI, including transitive dependencies.