NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2023-28709 — tomcat-embed-core

HIGHFix: apache/tomcat@5badf94

CVE-2023-28709 is a high-severity (CVSS 7.5) CWE-193 vulnerability in org.apache.tomcat.embed:tomcat-embed-core. EPSS puts its 30-day exploitation probability at 48.0% (99th percentile). A fix is available for org.apache.tomcat.embed:tomcat-embed-core — see the affected versions and patch details below.

Apache Tomcat: Fix for CVE-2023-24998 is incomplete

Also known asBIT-tomcat-2023-28709GHSA-cx6h-86xw-9x34
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-28709.

EPSS Exploitation Probability

via FIRST.org ↗
48.0%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.00%22.3%44.6%66.9%0.4%48.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat-coyote

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The fix for CVE-2023-24998 was incomplete for Apache Tomcat 11.0.0-M2 to 11.0.0-M4, 10.1.5 to 10.1.7, 9.0.71 to 9.0.73 and 8.5.85 to 8.5.87. If non-default HTTP connector settings were used such that the maxParameterCount could be reached using query string parameters and a request was submitted that supplied exactly maxParameterCount parameters in the query string, the limit for uploaded request parts could be bypassed with the potential for a denial of service to occur.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 11.0.0-M2&&< 11.0.0-M511.0.0-M5org.apache.tomcat.embed:tomcat-embed-core:11.0.0-M5
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 10.1.5&&< 10.1.810.1.8org.apache.tomcat.embed:tomcat-embed-core:10.1.8
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 9.0.71&&< 9.0.749.0.74org.apache.tomcat.embed:tomcat-embed-core:9.0.74
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 8.5.85&&< 8.5.888.5.88org.apache.tomcat:tomcat-coyote:8.5.88

Affected Products

3 products · 8 configurations
Application
tomcatapache
≥ 10.1.5 && ≤ 10.1.7
1 version
11.0.0
OS
debian linuxdebian
1 version
12.0
Application
7-mode transition toolnetapp
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat.embed:tomcat-embed-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat.embed:tomcat-embed-core to 11.0.0-M5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-28709 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

The impact for this flaw is considered moderate to match the Apache Software Foundation impact, considering the non-default configuration in CVE description. pki-servlet-engine has been obsoleted in Red Hat Enterprise Linux 8.9 and later by Tomcat, so no additional fixes for the engine would be made available.

Workaround published by Red Hat
No mitigation is currently available that meets Red Hat Product Security's standards for usability, deployment, applicability, or stability.
Source: Red Hat security advisory for CVE-2023-28709 (CC BY 4.0)
ProductFixed inAdvisory
JWS 5.7.4 releasetomcatRHSA-2023:4910
Red Hat Enterprise Linux 8tomcat-1:9.0.62-27.el8_9RHSA-2023:7065
Red Hat Enterprise Linux 9tomcat-1:9.0.62-37.el9_3RHSA-2023:6570
Red Hat JBoss Web Server 5.7 on RHEL 7jws5-tomcat-0:9.0.62-15.redhat_00013.1.el7jwsRHSA-2023:4909

Frequently Asked Questions

The fix for CVE-2023-24998 was incomplete for Apache Tomcat 11.0.0-M2 to 11.0.0-M4, 10.1.5 to 10.1.7, 9.0.71 to 9.0.73 and 8.5.85 to 8.5.87. If non-default HTTP connector settings were used such that the maxParameterCount could be reached using query string parameters and a request was submitted that supplied exactly maxParameterCount parameters in the query string, the limit for uploaded request parts could be bypassed with the potential for a denial of service to occur.
O3 Security · Impact-Aware SCA

Is CVE-2023-28709 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-28709: tomcat-embed DoS — Fixed in 11.0.0-M5