NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2023-24423 — gerrit-trigger

MEDIUMFix: jenkinsci/gerrit-trigger-plugin@691d76f

CVE-2023-24423 is a medium-severity (CVSS 6.5) Cross-Site Request Forgery (CSRF) vulnerability in com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger. A fix is available for com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger — see the affected versions and patch details below.

Cross-site request forgery in Jenkins Gerrit Trigger Plugin

Also known asGHSA-95jq-24cr-pgrq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-24423.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs43th percentile — riskier than 43% of all scored CVEsHighest risk
0.00%0.33%0.67%1.00%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A cross-site request forgery (CSRF) vulnerability in Jenkins Gerrit Trigger Plugin 2.38.0 and earlier allows attackers to rebuild previous builds triggered by Gerrit.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.sonyericsson.hudson.plugins.gerrit:gerrit-triggerall versions2.38.1com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger:2.38.1

Affected Products

1 product · 1 configurations
Application
gerrit triggerjenkins
< 2.38.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger to 2.38.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-24423 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A cross-site request forgery (CSRF) vulnerability in Jenkins Gerrit Trigger Plugin 2.38.0 and earlier allows attackers to rebuild previous builds triggered by Gerrit.
O3 Security · Impact-Aware SCA

Is CVE-2023-24423 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-24423: gerrit-trigger CSRF — Fixed in 2.38.1