NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-16552 — gerrit-trigger

MEDIUMFix: jenkinsci/gerrit-trigger-plugin@bdc94d3

CVE-2019-16552 is a medium-severity (CVSS 5.4) Incorrect Default Permissions vulnerability in com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger. A fix is available for com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger — see the affected versions and patch details below.

Missing permission check in Jenkins Gerrit Trigger Plugin

Also known asGHSA-4r39-f4rh-j6q8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.37%0.75%1.12%0.0%0.6%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A missing permission check in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials, or determine the existence of a file with a given path on the Jenkins master.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.sonyericsson.hudson.plugins.gerrit:gerrit-triggerall versions2.30.2com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger:2.30.2

Affected Products

1 product · 1 configurations
Application
gerrit triggerjenkins
≤ 2.30.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger to 2.30.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16552 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

A missing permission check in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials, or determine the existence of a file with a given path on the Jenkins master.
O3 Security · Impact-Aware SCA

Is CVE-2019-16552 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-16552: gerrit-trigger — Fixed in 2.30.2