NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2019-16551 — gerrit-trigger

HIGHFix: jenkinsci/gerrit-trigger-plugin@bdc94d3

CVE-2019-16551 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger. A fix is available for com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger — see the affected versions and patch details below.

Cross-Site Request Forgery in Jenkins Gerrit Trigger Plugin

Also known asGHSA-vmvp-2hhx-rgm8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk+0.17%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.45%0.91%1.36%0.1%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A cross-site request forgery vulnerability in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.sonyericsson.hudson.plugins.gerrit:gerrit-triggerall versions2.30.2com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger:2.30.2

Affected Products

1 product · 1 configurations
Application
gerrit triggerjenkins
≤ 2.30.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger to 2.30.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16551 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A cross-site request forgery vulnerability in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials.
O3 Security · Impact-Aware SCA

Is CVE-2019-16551 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-16551: gerrit-trigger CSRF — Fixed in 2.30.2