NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1000105 — gerrit-trigger

MEDIUMFix: jenkinsci/gerrit-trigger-plugin@a222f2d

CVE-2018-1000105 is a medium-severity (CVSS 4.3) CWE-863 vulnerability in com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger. A fix is available for com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger — see the affected versions and patch details below.

Incorrect Authorization in Jenkins Gerrit Trigger Plugin

Also known asGHSA-wrqc-q8p5-76m5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.78%1.18%0.0%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java, GerritServer.java, and PluginImpl.java that allows an attacker with Overall/Read access to retrieve some configuration information about Gerrit in Jenkins.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.sonyericsson.hudson.plugins.gerrit:gerrit-triggerall versions2.27.5com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger:2.27.5

Affected Products

1 product · 1 configurations
Application
gerrit triggerjenkins
≤ 2.27.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger to 2.27.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000105 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java, GerritServer.java, and PluginImpl.java that allows an attacker with Overall/Read access to retrieve some configuration information about Gerrit in Jenkins.
O3 Security · Impact-Aware SCA

Is CVE-2018-1000105 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1000105: gerrit-trigger — Fixed in 2.27.5