NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-45143 — tomcat-embed-core

HIGHFix: apache/tomcat@0cab3a5

CVE-2022-45143 is a high-severity (CVSS 7.5) CWE-116 vulnerability in org.apache.tomcat.embed:tomcat-embed-core. A fix is available for org.apache.tomcat.embed:tomcat-embed-core — see the affected versions and patch details below.

Apache Tomcat: JsonErrorReportValve escaping

Also known asBIT-tomcat-2022-45143GHSA-rq2w-37h9-vg94
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-45143.

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk+0.10%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.26%1.25%2.24%3.22%0.8%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-util☕org.apache.tomcat:tomcat-util

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The JsonErrorReportValve in Apache Tomcat 8.5.83, 9.0.40 to 9.0.68 and 10.1.0-M1 to 10.1.1 did not escape the type, message or description values. In some circumstances these are constructed from user provided data and it was therefore possible for users to supply values that invalidated or manipulated the JSON output.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 8.5.83&&< 8.5.848.5.84org.apache.tomcat.embed:tomcat-embed-core:8.5.84
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 9.0.40&&< 9.0.699.0.69org.apache.tomcat.embed:tomcat-embed-core:9.0.69
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 10.1.0&&< 10.1.210.1.2org.apache.tomcat.embed:tomcat-embed-core:10.1.2
☕Mavenorg.apache.tomcat:tomcat-catalina≥ 10.1.0&&< 10.1.210.1.2org.apache.tomcat:tomcat-catalina:10.1.2
☕Mavenorg.apache.tomcat:tomcat-util≥ 8.5.83&&< 8.5.848.5.84org.apache.tomcat:tomcat-util:8.5.84
☕Mavenorg.apache.tomcat:tomcat-util≥ 9.0.40&&< 9.0.699.0.69org.apache.tomcat:tomcat-util:9.0.69

Affected Products

1 product · 20 configurations
Application
tomcatapache
≥ 9.0.40 && < 9.0.69
3 versions
8.5.8310.1.010.1.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat.embed:tomcat-embed-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat.embed:tomcat-embed-core to 8.5.84 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-45143 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

Although it may be rated as CVSS 7.5, it's still considered a low impact flaw as according to the advisory report from Apache, user controlled data may occur in specific cases only and may alter some specific fields only. Red Hat Satellite does not include the affected Apache Tomcat, however, Tomcat is shipped with…

ProductFixed inAdvisory
Red Hat Enterprise Linux 8tomcat-1:9.0.87-1.el8_10.1RHSA-2024:3666
Red Hat Enterprise Linux 8.8 Extended Update Supporttomcat-1:9.0.87-1.el8_8.2RHSA-2024:3814
Red Hat Enterprise Linux 9tomcat-1:9.0.87-1.el9_4.1RHSA-2024:3307
Red Hat Fuse 7.12tomcatRHSA-2023:3954
Red Hat JBoss Web Server 5jws5-tomcatRHSA-2023:1664
Red Hat JBoss Web Server 5.7 on RHEL 7jws5-tomcat-0:9.0.62-13.redhat_00011.1.el7jwsRHSA-2023:1663
Red Hat support for Spring Boot 2.7.13tomcatRHSA-2023:4612

Frequently Asked Questions

The JsonErrorReportValve in Apache Tomcat 8.5.83, 9.0.40 to 9.0.68 and 10.1.0-M1 to 10.1.1 did not escape the type, message or description values. In some circumstances these are constructed from user provided data and it was therefore possible for users to supply values that invalidated or manipulated the JSON output.
O3 Security · Impact-Aware SCA

Is CVE-2022-45143 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-45143: tomcat-embed-core — Fixed in 8.5.84