NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-42252 — tomcat-embed-core

HIGHFix: apache/tomcat@0d089a1

CVE-2022-42252 is a high-severity (CVSS 7.5) CWE-444 vulnerability in org.apache.tomcat.embed:tomcat-embed-core. A fix is available for org.apache.tomcat.embed:tomcat-embed-core — see the affected versions and patch details below.

Apache Tomcat request smuggling via malformed content-length

Also known asBIT-tomcat-2022-42252GHSA-p22x-g9px-3945
Published
Updated
Affected
7 pkgs
Patched
7 / 7
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-42252.

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.69%1.38%2.08%0.1%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

7 pkgs affected
☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote☕org.apache.tomcat:tomcat-coyote

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

If Apache Tomcat 8.5.0 to 8.5.82, 9.0.0-M1 to 9.0.67, 10.0.0-M1 to 10.0.26 or 10.1.0-M1 to 10.1.0 was configured to ignore invalid HTTP headers via setting rejectIllegalHeader to false (the default for 8.5.x only), Tomcat did not reject a request containing an invalid Content-Length header making a request smuggling attack possible if Tomcat was located behind a reverse proxy that also failed to reject the request with the invalid header.

Affected Packages

7 total 7 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 8.5.0&&< 8.5.838.5.83org.apache.tomcat.embed:tomcat-embed-core:8.5.83
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 9.0.0-M1&&< 9.0.689.0.68org.apache.tomcat.embed:tomcat-embed-core:9.0.68
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 10.0.0-M1&&< 10.0.2710.0.27org.apache.tomcat.embed:tomcat-embed-core:10.0.27
☕Mavenorg.apache.tomcat.embed:tomcat-embed-core≥ 10.1.0-M1&&< 10.1.110.1.1org.apache.tomcat.embed:tomcat-embed-core:10.1.1
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 9.0.0-M1&&< 9.0.689.0.68org.apache.tomcat:tomcat-coyote:9.0.68
☕Mavenorg.apache.tomcat:tomcat-coyote≥ 10.0.0-M1&&< 10.0.2710.0.27org.apache.tomcat:tomcat-coyote:10.0.27

Affected Products

1 product · 4 configurations
Application
tomcatapache
≥ 10.1.0 && < 10.1.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat.embed:tomcat-embed-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat.embed:tomcat-embed-core to 8.5.83 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-42252 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

Red Hat Satellite does not include the affected Apache Tomcat, however, Tomcat is shipped with Red Hat Enterprise Linux and consumed by the Candlepin component of Satellite. Red Hat Satellite users are therefore advised to check the impact state of Red Hat Enterprise Linux, since any necessary fixes will be…

ProductFixed inAdvisory
Red Hat JBoss Web Server 5jws5-tomcatRHSA-2023:1664
Red Hat JBoss Web Server 5.7 on RHEL 7jws5-tomcat-0:9.0.62-13.redhat_00011.1.el7jwsRHSA-2023:1663

Frequently Asked Questions

If Apache Tomcat 8.5.0 to 8.5.82, 9.0.0-M1 to 9.0.67, 10.0.0-M1 to 10.0.26 or 10.1.0-M1 to 10.1.0 was configured to ignore invalid HTTP headers via setting rejectIllegalHeader to false (the default for 8.5.x only), Tomcat did not reject a request containing an invalid Content-Length header making a request smuggling attack possible if Tomcat was located behind a reverse proxy that also failed to reject the request with the invalid header.
O3 Security · Impact-Aware SCA

Is CVE-2022-42252 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-42252: tomcat-embed-core — Fixed in 8.5.83