NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2022-38545 — valine

CRITICALFix: xCss/Valine@c40826c

CVE-2022-38545 is a critical-severity (CVSS 9.6) Cross-site Scripting (XSS) vulnerability in valine. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for valine — see the affected versions and patch details below.

Valine code injection vulnerability

Also known asGHSA-mcvg-g9wx-v5vx
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 25, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
34.1%probability of exploitation in next 30 days
Moderate Risk+0.67%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
0.00%14.6%29.2%43.9%1.6%34.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

60other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
valinenpm
1Kdownloads / week

Description

Valine v1.4.18 was discovered to contain a remote code execution (RCE) vulnerability which allows attackers to execute arbitrary code via a crafted POST request.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmvalineall versions1.5.0npm install valine@1.5.0

Affected Products

1 product · 1 configurations
Application
valinevaline.js
1 version
1.4.18
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for valine, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update valine to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-38545 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Valine v1.4.18 was discovered to contain a remote code execution (RCE) vulnerability which allows attackers to execute arbitrary code via a crafted POST request.
O3 Security · Impact-Aware SCA

Is CVE-2022-38545 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-38545: valine RCE — Fixed in 1.5.0