NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2018-19289 — valine

MEDIUMFix: xCss/Valine@32d4d5e

CVE-2018-19289 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in valine. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for valine — see the affected versions and patch details below.

Valine HTML Injection

Also known asGHSA-hhrp-qm88-xjr3
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.15%1.73%0.3%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

60other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
valinenpm
3Kdownloads / week

Description

An issue was discovered in Valine v1.3.3. It allows HTML injection, which can be exploited for JavaScript execution via an EMBED element in conjunction with a .pdf file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmvalineall versions1.3.4npm install valine@1.3.4

Affected Products

1 product · 1 configurations
Application
valinevaline.js
1 version
1.3.3
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for valine, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update valine to 1.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-19289 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in Valine v1.3.3. It allows HTML injection, which can be exploited for JavaScript execution via an EMBED element in conjunction with a .pdf file.
O3 Security · Impact-Aware SCA

Is CVE-2018-19289 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2018-19289: valine — Fixed in 1.3.4