NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2020-28847 — valine

MEDIUM

CVE-2020-28847 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in valine. A fix is available for valine — see the affected versions and patch details below.

Cross site scripting in valine

Also known asGHSA-6xvq-2gj8-4276
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.2%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

60other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
valinenpm
3Kdownloads / week

Description

valine is a fast, simple & powerful comment system. Cross Site Scripting (XSS) vulnerability in xCss Valine v1.4.14 via the nick parameter to /classes/Comment. A fix was released in version 1.4.15.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmvalineall versions1.4.15npm install valine@1.4.15

Affected Products

1 product · 1 configurations
Application
valinevaline.js
1 version
1.4.14

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for valine, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update valine to 1.4.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-28847 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

valine is a fast, simple & powerful comment system. Cross Site Scripting (XSS) vulnerability in xCss Valine v1.4.14 via the nick parameter to /classes/Comment. A fix was released in version 1.4.15.
O3 Security · Impact-Aware SCA

Is CVE-2020-28847 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-28847: valine XSS — Fixed in 1.4.15