NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-30429 — neos

MEDIUM

CVE-2022-30429 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in neos/neos. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for neos/neos — see the affected versions and patch details below.

Neos CMS vulnerable to XSS in various backend modules

Also known asBIT-neos-2022-30429GHSA-7m9h-v68w-pfw3
Published
Updated
Affected
7 pkgs
Patched
7 / 7
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs49th percentile — riskier than 49% of all scored CVEsHighest risk
0.00%0.37%0.74%1.10%0.5%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

7 pkgs affected
🐘neos/neos🐘neos/neos🐘neos/neos🐘neos/neos🐘neos/neos🐘neos/neos🐘neos/neos

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in Neos CMS allow attackers with the editor role or higher to inject arbitrary script or HTML code using the editor function, the deletion of assets, or a workspace title. The vulnerabilities were found in versions 3.3.29 and 8.0.1 and could also be present in all intermediate versions.

Affected Packages

7 total 7 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistneos/neos≥ 3.3.0&&< 4.4.04.4.0composer require neos/neos:^4.4.0
🐘Packagistneos/neos≥ 5.3.0&&< 5.3.105.3.10composer require neos/neos:^5.3.10
🐘Packagistneos/neos≥ 7.0.0&&< 7.0.97.0.9composer require neos/neos:^7.0.9
🐘Packagistneos/neos≥ 7.1.0&&< 7.1.77.1.7composer require neos/neos:^7.1.7
🐘Packagistneos/neos≥ 7.2.0&&< 7.2.67.2.6composer require neos/neos:^7.2.6
🐘Packagistneos/neos≥ 7.3.0&&< 7.3.47.3.4composer require neos/neos:^7.3.4

Affected Products

1 product · 6 configurations
Application
neos cmsneos
≥ 8.0.0 && < 8.0.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for neos/neos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update neos/neos to 4.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-30429 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in Neos CMS allow attackers with the editor role or higher to inject arbitrary script or HTML code using the editor function, the deletion of assets, or a workspace title. The vulnerabilities were found in versions 3.3.29 and 8.0.1 and could also be present in all intermediate versions.
O3 Security · Impact-Aware SCA

Is CVE-2022-30429 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-30429: neos XSS — Fixed in 4.4.0