Privilege Escalation in TYPO3 NeosGHSA-43cf-7f3h-38rg
MEDIUMGHSA-43cf-7f3h-38rg is a medium-severity (CVSS 4.2) vulnerability in neos/neos. A fix is available for neos/neos — see the affected versions and patch details below.
Real-World Exposure
neos/neos🐘neos/neosReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It has been discovered that TYPO3 Neos is vulnerable to Privilege Escalation. Logged in editors could access, create and modify content nodes that exist in the workspace of other editors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | neos/neos | ≥ 1.1.0&&< 1.1.3 | 1.1.3composer require neos/neos:^1.1.3 |
| 🐘Packagist | neos/neos | ≥ 1.2.0&&< 1.2.3 | 1.2.3composer require neos/neos:^1.2.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for neos/neos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update neos/neos to 1.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-43cf-7f3h-38rg is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is GHSA-43cf-7f3h-38rg in your dependencies?
Find it across Packagist, including transitive dependencies.