Cross-site Scripting vulnerabilities in NeosGHSA-6cj3-rc4p-f38f
GHSA-6cj3-rc4p-f38f is a security vulnerability in neos/neos. A fix is available for neos/neos — see the affected versions and patch details below.
Real-World Exposure
neos/neos🐘neos/neosReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It has been discovered that Neos is vulnerable to several XSS attacks. Through these vulnerabilities, an attacker could tamper with page rendering, redirect victims to a fake login page, or capture user credentials (such as cookies). With the potential backdoor upload an attacker could gain access to the server itself, to an extent mainly limited by the server setup.
Reflected Cross-Site Scripting (SXSS) with authentication
A Neos backend user with permission to modify content can insert JavaScript instructions into content elements. The browser will execute the script in "Print" preview mode. A Neos backend user who can modify his profile information ("Title", "First Name", "Last name", "Middle Name", "Other Name") can inject JavaScript instructions in those parameters. Once set up, an administrator who wants to edit this user account will execute the code. Both attack vectors require a valid Neos backend user account.
Reflected Cross-Site Scripting (RXSS) without authentication
A non-persistent XSS using parameters passed during plugin execution is possible. If invalid parameters are passed, an error message may be shown (depending on the context Neos runs in and how the parameters are handled) that contains the unescaped parameter value.
Note: Through the HTML content type the inclusion of arbitrary JavaScript is still possible for users with a valid Neos backend account. If you want to prohibit that, disable the nodetype or restrict access.
Potential backdoor upload
Through an issue with the underlying Flow framework (see the related Flow advisory Flow-SA-2015-001) any editor with access to the Media Management module can upload server side script files (when using Neos 2.0.x). If those scripts are executed by the server when accessed through their public URL, anything not blocked through other means is possible (information disclosure, placement of backdoors, data removal, …).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | neos/neos | ≥ 1.2.0&&< 1.2.13 | 1.2.13composer require neos/neos:^1.2.13 |
| 🐘Packagist | neos/neos | ≥ 2.0.0&&< 2.0.4 | 2.0.4composer require neos/neos:^2.0.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for neos/neos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update neos/neos to 1.2.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6cj3-rc4p-f38f is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-6cj3-rc4p-f38f in your dependencies?
Find it across Packagist, including transitive dependencies.