NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-28146 — ci-with-toad-edge

MEDIUMFix: jenkinsci/ci-with-toad-edge-plugin@49d4b85

CVE-2022-28146 is a medium-severity (CVSS 6.5) Path Traversal vulnerability in org.jenkins-ci.plugins:ci-with-toad-edge. A fix is available for org.jenkins-ci.plugins:ci-with-toad-edge — see the affected versions and patch details below.

Arbitrary file read vulnerability in Jenkins Continuous Integration with Toad Edge Plugin

Also known asGHSA-8p4x-fq8v-xhv4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.34%1.00%1.67%2.34%0.8%1.8%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:ci-with-toad-edge

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Continuous Integration with Toad Edge Plugin 2.3 and earlier allows attackers with Item/Configure permission to read arbitrary files on the Jenkins controller by specifying an input folder on the Jenkins controller as a parameter to its build steps.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:ci-with-toad-edgeall versions2.4org.jenkins-ci.plugins:ci-with-toad-edge:2.4

Affected Products

1 product · 1 configurations
Application
continuous integration with toad edgejenkins
≤ 2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:ci-with-toad-edge, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:ci-with-toad-edge to 2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-28146 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Jenkins Continuous Integration with Toad Edge Plugin 2.3 and earlier allows attackers with Item/Configure permission to read arbitrary files on the Jenkins controller by specifying an input folder on the Jenkins controller as a parameter to its build steps.
O3 Security · Impact-Aware SCA

Is CVE-2022-28146 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-28146: ci-with-toad-edge — Fixed in 2.4