NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-28147 — ci-with-toad-edge

MEDIUMFix: jenkinsci/ci-with-toad-edge-plugin@2b65d62

CVE-2022-28147 is a medium-severity (CVSS 4.3) CWE-862 vulnerability in org.jenkins-ci.plugins:ci-with-toad-edge. A fix is available for org.jenkins-ci.plugins:ci-with-toad-edge — see the affected versions and patch details below.

Missing permission check in Jenkins Continuous Integration with Toad Edge Plugin

Also known asGHSA-8hh2-rxm8-7fj8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.42%0.83%1.25%0.0%0.7%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:ci-with-toad-edge

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A missing permission check in Jenkins Continuous Integration with Toad Edge Plugin 2.3 and earlier allows attackers with Overall/Read permission to check for the existence of an attacker-specified file path on the Jenkins controller file system.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:ci-with-toad-edgeall versions2.4org.jenkins-ci.plugins:ci-with-toad-edge:2.4

Affected Products

1 product · 1 configurations
Application
continuous integration with toad edgejenkins
≤ 2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:ci-with-toad-edge, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:ci-with-toad-edge to 2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-28147 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

A missing permission check in Jenkins Continuous Integration with Toad Edge Plugin 2.3 and earlier allows attackers with Overall/Read permission to check for the existence of an attacker-specified file path on the Jenkins controller file system.
O3 Security · Impact-Aware SCA

Is CVE-2022-28147 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-28147: ci-with-toad-edge — Fixed in 2.4