CVE-2022-26612 — hadoop-common
CRITICALCVE-2022-26612 is a critical-severity (CVSS 9.8) CWE-59 vulnerability in org.apache.hadoop:hadoop-common. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.hadoop:hadoop-common — see the affected versions and patch details below.
Arbitrary file write in FileUtil#unpackEntries on Windows
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.hadoop:hadoop-common☕org.apache.hadoop:hadoop-common☕org.apache.hadoop:hadoop-commonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Hadoop, The unTar function uses unTarUsingJava function on Windows and the built-in tar utility on Unix and other OSes. As a result, a TAR entry may create a symlink under the expected extraction directory which points to an external directory. A subsequent TAR entry may extract an arbitrary file into the external directory using the symlink name. This however would be caught by the same targetDirPath check on Unix because of the getCanonicalPath call. However on Windows, getCanonicalPath doesn't resolve symbolic links, which bypasses the check. unpackEntries during TAR extraction follows symbolic links which allows writing outside expected base directory on Windows. This was addressed in Apache Hadoop 2.10.2, 3.2.3, 3.3.3, and 3.4.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hadoop:hadoop-common | ≥ 3.2.0&&< 3.2.3 | 3.2.3org.apache.hadoop:hadoop-common:3.2.3 |
| ☕Maven | org.apache.hadoop:hadoop-common | all versions | 2.10.2org.apache.hadoop:hadoop-common:2.10.2 |
| ☕Maven | org.apache.hadoop:hadoop-common | ≥ 3.3.0&&< 3.3.3 | 3.3.3org.apache.hadoop:hadoop-common:3.3.3 |
Affected Products
hadoopapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hadoop:hadoop-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hadoop:hadoop-common to 3.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-26612 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-26612 in your dependencies?
Find it across Maven, including transitive dependencies.