CVE-2013-2192 — hadoop-common
CVE-2013-2192 is a Improper Authentication vulnerability in org.apache.hadoop:hadoop-common. A fix is available for org.apache.hadoop:hadoop-common — see the affected versions and patch details below.
Improper Authentication in Apache Hadoop
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.hadoop:hadoop-common☕org.apache.hadoop:hadoop-commonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The RPC protocol implementation in Apache Hadoop 2.x before 2.0.6-alpha, 0.23.x before 0.23.9, and 1.x before 1.2.1, when the Kerberos security features are enabled, allows man-in-the-middle attackers to disable bidirectional authentication and obtain sensitive information by forcing a downgrade to simple authentication.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hadoop:hadoop-common | ≥ 2.0.0&&< 2.0.6-alpha | 2.0.6-alphaorg.apache.hadoop:hadoop-common:2.0.6-alpha |
| ☕Maven | org.apache.hadoop:hadoop-common | ≥ 0.23.0&&< 0.23.9 | 0.23.9org.apache.hadoop:hadoop-common:0.23.9 |
Affected Products
hadoopapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hadoop:hadoop-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hadoop:hadoop-common to 2.0.6-alpha or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-2192 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss A-MQ 6.1 | see advisory | RHSA-2014:0401 |
| Red Hat JBoss Fuse 6.1 | see advisory | RHSA-2014:0400 |
| RHEV Manager version 3.3 | jasperreports-server-pro-0:5.5.0-4.el6ev | RHSA-2014:0037 |
Frequently Asked Questions
Is CVE-2013-2192 in your dependencies?
Find it across Maven, including transitive dependencies.