NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2014-0229 — hadoop-common

MEDIUM

CVE-2014-0229 is a medium-severity (CVSS 6.5) CWE-264 vulnerability in org.apache.hadoop:hadoop-common. A fix is available for org.apache.hadoop:hadoop-common — see the affected versions and patch details below.

Improper Authentication in Apache Hadoop

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.70%1.40%2.10%0.4%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.hadoop:hadoop-common☕org.apache.hadoop:hadoop-common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Hadoop 0.23.x before 0.23.11 and 2.x before 2.4.1, as used in Cloudera CDH 5.0.x before 5.0.2, do not check authorization for the (1) refreshNamenodes, (2) deleteBlockPool, and (3) shutdownDatanode HDFS admin commands, which allows remote authenticated users to cause a denial of service (DataNodes shutdown) or perform unnecessary operations by issuing a command.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.hadoop:hadoop-common≥ 0.23.0&&< 0.23.110.23.11org.apache.hadoop:hadoop-common:0.23.11
☕Mavenorg.apache.hadoop:hadoop-common≥ 2.0.0&&< 2.4.12.4.1org.apache.hadoop:hadoop-common:2.4.1

Affected Products

2 products · 25 configurations
Application
hadoopapache
22 versions
0.23.00.23.10.23.30.23.40.23.50.23.60.23.70.23.80.23.90.23.102.0.02.0.1
Application
cdhcloudera
1 version
5.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hadoop:hadoop-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.hadoop:hadoop-common to 0.23.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0229 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Apache Hadoop 0.23.x before 0.23.11 and 2.x before 2.4.1, as used in Cloudera CDH 5.0.x before 5.0.2, do not check authorization for the (1) refreshNamenodes, (2) deleteBlockPool, and (3) shutdownDatanode HDFS admin commands, which allows remote authenticated users to cause a denial of service (DataNodes shutdown) or perform unnecessary operations by issuing a command.
O3 Security · Impact-Aware SCA

Is CVE-2014-0229 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-0229: hadoop-common DoS — Fixed in 0.23.11