CVE-2022-25168 is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in org.apache.hadoop:hadoop-common. A fix is available for org.apache.hadoop:hadoop-common — see the affected versions and patch details below.
Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.hadoop:hadoop-common☕org.apache.hadoop:hadoop-common☕org.apache.hadoop:hadoop-commonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Hadoop's FileUtil.unTar(File, File) API does not escape the input file name before being passed to the shell. An attacker can inject arbitrary commands. This is only used in Hadoop 3.3 InMemoryAliasMap.completeBootstrapTransfer, which is only ever run by a local user. It has been used in Hadoop 2.x for yarn localization, which does enable remote code execution. It is used in Apache Spark, from the SQL command ADD ARCHIVE. As the ADD ARCHIVE command adds new binaries to the classpath, being able to execute shell scripts does not confer new permissions to the caller. SPARK-38305. "Check existence of file before untarring/zipping", which is included in 3.3.0, 3.1.4, 3.2.2, prevents shell commands being executed, regardless of which version of the hadoop libraries are in use. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.3 or upper (including HADOOP-18136).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hadoop:hadoop-common | ≥ 2.0.0&&< 2.10.2 | 2.10.2org.apache.hadoop:hadoop-common:2.10.2 |
| ☕Maven | org.apache.hadoop:hadoop-common | ≥ 3.0.0-alpha&&< 3.2.4 | 3.2.4org.apache.hadoop:hadoop-common:3.2.4 |
| ☕Maven | org.apache.hadoop:hadoop-common | ≥ 3.3.0&&< 3.3.3 | 3.3.3org.apache.hadoop:hadoop-common:3.3.3 |
Affected Products
hadoopapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hadoop:hadoop-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hadoop:hadoop-common to 2.10.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25168 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2022-25168 in your dependencies?
Find it across Maven, including transitive dependencies.