NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2022-24728 — ckeditor4

MEDIUMFix: ckeditor/ckeditor4@d158413

CVE-2022-24728 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in ckeditor4. A fix is available for ckeditor4 — see the affected versions and patch details below.

Cross-site Scripting in CKEditor4

Also known asBIT-drupal-2022-24728BIT-drupal-2022-24729CVE-2022-24729DRUPAL-CORE-2022-005GHSA-4fc4-4p5g-6w89GHSA-f6rf-9m92-x2hh
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24728.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.49%0.90%1.30%1.70%1.1%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

27other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ckeditor4npm
66Kdownloads / week

Description

Affected packages

The vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4.

Impact

A potential vulnerability has been discovered in CKEditor 4 HTML processing core module. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.18.0.

Patches

The problem has been recognized and patched. The fix will be available in version 4.18.0.

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

Acknowledgements

The CKEditor 4 team would like to thank GHSL team member Kevin Backhouse (@kevinbackhouse) for recognizing and reporting this vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmckeditor4all versions4.18.0npm install ckeditor4@4.18.0

Affected Products

9 products · 19 configurations
Application
ckeditorckeditor
≥ 4.0 && < 4.18.0
range
Application
drupaldrupal
≥ 9.3.0 && < 9.3.8
range
OS
fedorafedoraproject
2 versions
3637
Application
application expressoracle
< 22.1.1
range
Application
commerce merchandisingoracle
1 version
11.3.2
Application
financial services analytical applications infrastructureoracle
≥ 8.0.7.0.0 && ≤ 8.1.0.0.0
3 versions
8.1.1.08.1.2.08.1.2.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ckeditor4, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ckeditor4 to 4.18.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24728 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

UbuntuMEDIUM

Frequently Asked Questions

### Affected packages The vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. ### Impact A potential vulnerability has been discovered in CKEditor 4 HTML processing core module. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.18.0. ### Patches The problem has been recognized and patched. The fix will be available in version 4.18.0. ### For more information Email us at [email protected]
O3 Security · Impact-Aware SCA

Is CVE-2022-24728 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-24728: ckeditor4 — Fixed in 4.18.0