NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 Bitnami
Not in CISA KEV

Cross-site Scripting in CKEditor4GHSA-f6rf-9m92-x2hh

Fix: ckeditor/ckeditor4@d158413

GHSA-f6rf-9m92-x2hh is a Cross-site Scripting (XSS) vulnerability in drupal. A fix is available for drupal — see the affected versions and patch details below.

Also known asBIT-drupal-2022-24729CVE-2022-24728CVE-2022-24729DRUPAL-CORE-2022-005GHSA-4fc4-4p5g-6w89
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-f6rf-9m92-x2hh.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.49%0.90%1.30%1.70%1.1%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

27other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ckeditor4npm
73Kdownloads / week

Description

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦Bitnamidrupal≥ 8.0.0&&< 9.2.159.2.15

Affected Products

9 products · 19 configurations
Application
ckeditorckeditor
≥ 4.0 && < 4.18.0
range
Application
drupaldrupal
≥ 9.3.0 && < 9.3.8
range
OS
fedorafedoraproject
2 versions
3637
Application
application expressoracle
< 22.1.1
range
Application
commerce merchandisingoracle
1 version
11.3.2
Application
financial services analytical applications infrastructureoracle
≥ 8.0.7.0.0 && ≤ 8.1.0.0.0
3 versions
8.1.1.08.1.2.08.1.2.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal to 9.2.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f6rf-9m92-x2hh is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.
O3 Security · Impact-Aware SCA

Is GHSA-f6rf-9m92-x2hh in your dependencies?

Find it across Bitnami, including transitive dependencies.

Cross-site Scripting in CKEditor4