NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-24815 — ckeditor4

MEDIUMFix: ckeditor/ckeditor4@8ed1a3c

CVE-2024-24815 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in ckeditor4. A fix is available for ckeditor4 — see the affected versions and patch details below.

CKEditor4 Cross-site scripting (XSS) vulnerability caused by incorrect CDATA detection

Also known asGHSA-fq6h-4g8v-qqvm
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-24815.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.40%0.80%1.21%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

27other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ckeditor4npm
73Kdownloads / week

Description

Affected packages

The vulnerability has been discovered in the core HTML parsing module and may affect all editor instances that:

Impact

A potential vulnerability has been discovered in CKEditor 4 HTML processing core module. The vulnerability allowed to inject malformed HTML content bypassing Advanced Content Filtering mechanism, which could result in executing JavaScript code. An attacker could abuse faulty CDATA content detection and use it to prepare an intentional attack on the editor. It affects all users using the CKEditor 4 at version < 4.24.0-lts.

Patches

The problem has been recognized and patched. The fix will be available in version 4.24.0-lts.

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

Acknowledgements

The CKEditor 4 team would like to thank Michal Frýba from ALEF NULA for recognizing and reporting this vulnerability.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmckeditor4all versions4.24.0-ltsnpm install ckeditor4@4.24.0-lts
🐘Packagistckeditor/ckeditorall versions4.24.0composer require ckeditor/ckeditor:^4.24.0

Affected Products

1 product · 1 configurations
Application
ckeditorckeditor
≥ 4.0 && < 4.24.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ckeditor4, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ckeditor4 to 4.24.0-lts or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-24815 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Affected packages The vulnerability has been discovered in the core HTML parsing module and may affect all editor instances that: * Enabled [full-page editing](https://ckeditor.com/docs/ckeditor4/latest/features/fullpage.html) mode, * or enabled [CDATA](https://ckeditor.com/docs/ckeditor4/latest/api/CKEDITOR_dtd.html#property-S-cdata) elements in [Advanced Content Filtering](https://ckeditor.com/docs/ckeditor4/latest/guide/dev_advanced_content_filter.html) configuration (defaults to `script` and `style` elements). ### Impact A potential vulnerability has been discovered in CKEditor 4 HTM
O3 Security · Impact-Aware SCA

Is CVE-2024-24815 in your dependencies?

Find it across npm, Packagist, including transitive dependencies.

CVE-2024-24815: ckeditor4 — Fixed in 4.24.0-lts