NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-41165 — ckeditor4

MEDIUM

CVE-2021-41165 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in ckeditor4. A fix is available for ckeditor4 — see the affected versions and patch details below.

HTML comments vulnerability allowing to execute JavaScript code

Also known asBIT-drupal-2021-41165GHSA-7h26-63m7-qhf2
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.69%1.38%2.07%0.1%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

27other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ckeditor4npm
66Kdownloads / week

Description

Affected packages

The vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4.

Impact

A potential vulnerability has been discovered in CKEditor 4 HTML processing core module. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0.

Patches

The problem has been recognized and patched. The fix will be available in version 4.17.0.

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

Acknowledgements

The CKEditor 4 team would like to thank William Bowling (wbowling) for recognizing and reporting this vulnerability.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmckeditor4all versions4.17.0npm install ckeditor4@4.17.0
🐘Packagistckeditor/ckeditorall versions4.17.0composer require ckeditor/ckeditor:^4.17.0

Affected Products

9 products · 21 configurations
Application
ckeditorckeditor
< 4.17.0
range
Application
drupaldrupal
≥ 9.2.0 && < 9.2.9
range
Application
agile product lifecycle managementoracle
1 version
9.3.6
Application
application expressoracle
< 22.1
range
Application
banking apisoracle
≥ 18.1 && ≤ 18.3
4 versions
19.119.220.121.1
Application
banking digital experienceoracle
≥ 18.1 && ≤ 18.3
4 versions
19.119.220.121.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ckeditor4, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ckeditor4 to 4.17.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-41165 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Affected packages The vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. ### Impact A potential vulnerability has been discovered in CKEditor 4 HTML processing core module. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. ### Patches The problem has been recognized and patched. The fix will be available in version 4.17.0. ### For more information Email us at security@cks
O3 Security · Impact-Aware SCA

Is CVE-2021-41165 in your dependencies?

Find it across npm, Packagist, including transitive dependencies.

CVE-2021-41165: ckeditor4 — Fixed in 4.17.0