CVE-2021-22569 — protobuf-java
MEDIUMCVE-2021-22569 is a medium-severity (CVSS 5.5) CWE-696 vulnerability in com.google.protobuf:protobuf-java. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for com.google.protobuf:protobuf-java — see the affected versions and patch details below.
A potential Denial of Service issue in protobuf-java
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2021-22569.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.google.protobuf:protobuf-java☕com.google.protobuf:protobuf-java☕com.google.protobuf:protobuf-java☕com.google.protobuf:protobuf-kotlin☕com.google.protobuf:protobuf-kotlin💎google-protobufReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A potential Denial of Service issue in protobuf-java was discovered in the parsing procedure for binary data.
Reporter: OSS-Fuzz
Affected versions: All versions of Java Protobufs (including Kotlin and JRuby) prior to the versions listed below. Protobuf "javalite" users (typically Android) are not affected.
Severity
CVE-2021-22569 High - CVSS Score: 7.5, An implementation weakness in how unknown fields are parsed in Java. A small (~800 KB) malicious payload can occupy the parser for several minutes by creating large numbers of short-lived objects that cause frequent, repeated GC pauses.
Proof of Concept
For reproduction details, please refer to the oss-fuzz issue that identifies the specific inputs that exercise this parsing weakness.
Remediation and Mitigation
Please update to the latest available versions of the following packages:
- protobuf-java (3.16.1, 3.18.2, 3.19.2)
- protobuf-kotlin (3.18.2, 3.19.2)
- google-protobuf [JRuby gem only] (3.19.2)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.google.protobuf:protobuf-java | all versions | 3.16.1com.google.protobuf:protobuf-java:3.16.1 |
| ☕Maven | com.google.protobuf:protobuf-java | ≥ 3.18.0&&< 3.18.2 | 3.18.2com.google.protobuf:protobuf-java:3.18.2 |
| ☕Maven | com.google.protobuf:protobuf-java | ≥ 3.19.0&&< 3.19.2 | 3.19.2com.google.protobuf:protobuf-java:3.19.2 |
| ☕Maven | com.google.protobuf:protobuf-kotlin | ≥ 3.18.0&&< 3.18.2 | 3.18.2com.google.protobuf:protobuf-kotlin:3.18.2 |
| ☕Maven | com.google.protobuf:protobuf-kotlin | ≥ 3.19.0&&< 3.19.2 | 3.19.2com.google.protobuf:protobuf-kotlin:3.19.2 |
| 💎RubyGems | google-protobuf | all versions | 3.19.2bundle update google-protobuf --conservative |
Affected Products
google-protobufgoogleprotobuf-javagoogleprotobuf-kotlingooglecommunications cloud native core consoleoraclecommunications cloud native core network repository functionoraclecommunications cloud native core policyoracleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.google.protobuf:protobuf-java, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.google.protobuf:protobuf-java to 3.16.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-22569 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat build of Quarkus 2.7.5 | protobuf-java | RHSA-2022:4623 |
| Red Hat Fuse 7.11 | protobuf-java | RHSA-2022:5532 |
| RHINT Camel-Q 2.2.1 | see advisory | RHSA-2022:1013 |
| RHINT Debezium 1.9.7 | protobuf-java | RHSA-2022:7896 |
| RHINT Service Registry 2.3.0 GA | protobuf-java | RHSA-2022:6835 |
| RHPAM 7.13.0 async | protobuf-java | RHSA-2022:5903 |
| Text-Only RHOAR | protobuf-java | RHSA-2022:8761 |
Frequently Asked Questions
Is CVE-2021-22569 in your dependencies?
Find it across Maven, RubyGems, including transitive dependencies.